How to Enable Multisite in WordPress

Posted

This video screencast is a quick tutorial for how to set up WordPress 3.0 in multisite mode. The WordPress codex has written instructions if you want to use those as well.

YouTube Preview Image

Update the wp-config.php file

You will need to add this line of code to your wp-config.php to make the multisite function accessible:

define('WP_ALLOW_MULTISITE', true);

Links

WordPress codex documentation for using multisite:

http://codex.wordpress.org/Create_A_Network

How to map top level domains in multisite:

http://verysimple.com/2010/07/09/install-wordpress-3-with-multiple-tlds/

http://ottopress.com/2010/wordpress-3-0-multisite-domain-mapping-tutorial/

About Devin

I'm a WordPress developer based in Austin, Texas. Follow my projects on GitHub, or more general WordPress ramblings as @devinsays on twitter.

114 thoughts on “How to Enable Multisite in WordPress

  1. Adam wrote:

    Where is httpd.conf??

  2. jack wrote:

    I tried to install follow the video. When visit the new created mysite, shows error 404 page.

    The error mesage is
    PHP Warning: chmod() [function.chmod]: No such file or directory in /home/abc/public_html/prepare_removal.php on line 110

    How to fix this?

    Thanks

  3. cisco wrote:

    hello!
    can i use the multisite option even without using a subdomain and just a completely different domain? if yes, how?

    thanks

  4. Theo wrote:

    Thank you for this post and the video. I just want to add as contribution that, after you setup your multisite with wordpress 3, you can go to http://www.YOURSITE.com/wp-signup.php to register a new site if you don’t want to do it inside your control panel as super admin.

    http://www.YOURSITE.com/wp-signup.php should also be the link you provide to other to allow them to create new site on your blog.

    Again thanks for your post

  5. Pingback: How to migrate multiple blogs into WordPress 3.0 « djchuang.com

  6. Shaun Butler wrote:

    @Devin – Thanks, this is a handy tutorial :)

  7. Jack wrote:

    Fantastic work mate. That was very easy to follow :) Now time to find a theme that works with the multi user function.

  8. Evelien wrote:

    My host will not allow me to put a .htaccess file. Does this mean I cannot use the multi-site option?
    I am now running multiple installs of WP 2.9.2 and I would love to get rid of the duplication of the WP code for each of my blogs.

    • Max wrote:

      You need a new host… decent hosting is cheap (as little as $10 a month) so really no need to put up with that.

  9. I upgraded from 2.92 to 3.0 and just tried to implement multisite but did not get a network link in the tools menu as advertized.
    I double checked that
    define(‘WP_ALLOW_MULTISITE’, true);
    is in the wp-config.php

    Any suggestions?

  10. Todd Jordan wrote:

    Great video! Was able to use this and in 10 minutes converted one of my sites to multi-site.
    Well done.

  11. Evelien wrote:

    @County
    Some people say it is
    define(‘WP_ALLOW_MULTISITE’, true);
    others say it is
    define(‘WP_ENABLE_MULTISITE’, true);

    I did both and that got me the multisite links…

    Unfortunately I am havig trouble combining it with WPML now, but that is another story…

  12. Riccardo wrote:

    Thanks for sharing! Great!

  13. Jelskedei wrote:

    I cannot see the tutorial video, I look at a Mac with Firefox and/or Safari. Both nothing but a white square. Its a pitty because I was curious about the tutorial.

    • Devin wrote:

      The video was encoded for YouTube. You’d need flash installed for it to display correctly. Try watching it directly on the YouTube site if you are having troubles.

  14. Jelskedei wrote:

    Thanks, After a while I got it on both browsers. I never had this before, such a long time before the video started, it was maybe busy or it was too hot (in Holland). But anyway, thanks a lot for your support and help.

  15. Sri wrote:

    Hi,
    After enabling multisite, would it let me use the same username and password for all my existing users among all the sites ?

    Thanks

  16. Pingback: WordPress 3.0 – The Ultimate Roundup For Developers & Users | KreativeThemes.com

  17. juliana wrote:

    Thank You very MUCH!!! It really works!!!!

  18. marco wrote:

    This is all fine and dandy for those that have never used WP and are starting fresh, but what about those that have been using a single WP installation and want to migrate to Mulstisite>?

    • Devin wrote:

      Same steps. (Backup first :)

      • Max wrote:

        And be careful if you have had the install for a long time (permalink problems) – codex does not recommend you do a switch if your site has been running for a long time.

        Check http://codex.wordpress.org/Create_A_Network — specifically the bit titled “WordPress Settings Requirements”, where they say you cannot choose Sub-Directory install if your site has been running for more than a month (although they claim to be fixing this in later versions).

  19. marco wrote:

    Andrea helped me with the issue of having a WP site set up for “more than a month”-and thus not able to do subdirectories.

    http://tinyurl.com/2f2dlf2

  20. Rob wrote:

    I have successfully enabled multisite, installed MU Domain Mapping and added a second site mapped to a new domain. Everything is working fine, but I have a question about privacy:

    My original site is my business site and the new site is entirely personal, and supposed to be anonymous. However, when you watch the browser’s (firefox) path to the new site while it loads (in the address bar at the bottom), you can see it hit the original site address just before the plugin maps it to the new site domain. Occasionally when the servers are busy you can see “waiting for originalsite.com” before it gets mapped.

    Is there any way to keep visitors to the new site from ever seeing the address of the original site?

    • Devin wrote:

      I don’t have experience with that. Anyone else? Are you sure that none of your images/scripts/etc call files from your other site?

    • Max wrote:

      MU Domain Mapping works with a 301 Redirect. If you are keen eyed and on a low connection you will see that as the server sends the redirect header, and then the browser requests the new URL.

      There is really not much you can do to prevent that… On a fast connection and server it would be near instantaneous (provided the new domain name is already in the DNS cache).

  21. Devin Walker wrote:

    Awesome article, thanks for the help! I’ll be blogging about enabling WordPress multisite this on my website soon. Cool name also!

  22. Shawn H wrote:

    I installed this site as a multisite on my domain. I am using the Thesis theme for all my site. On the multisite install, I can’t find the install files for my new sub sites. I need to change for the pictures in that rotator folder, which is inside the wp-content folder. I only have the master install files, not the install files for my sub sites. The site is working correctly, so the pictures have to be somewhere. I checked using my ftp client and also through the file manager in cpanel. Any thoughts?

    • Devin wrote:

      I’d view the image (right click, choose “view image”) and see what the path is.

  23. Semhal wrote:

    Awesome tutorial and extremely helpful! Thanks so much. You rock! :-)

    Cheers,

    Semhal

  24. Muhammad Wasim wrote:

    very nice tutorial. thanks!

  25. Dave T wrote:

    Our existing site runs 3.0 and does not have the network enabled. I followed the steps from the WordPress site to enable the network. Once I activate Network and add the code supplied by WordPress to wp-config and .htaccess and then logout, it says it doesn’t have a database connection. I commented out the new code from the wpconfig and then it works again but not as a network site. Is there something else that needs to be done. We have 2 installs on the site(one is for the main site and the other is press releases) and would prefer to have one multi-user site that we basically clone to our other translated regions.

  26. Pingback: Shun the Plugin: 100 WordPress Code Snippets from Across the Net | WordPress, Multisite and BuddyPress plugins, themes, news and help – WPMU.org

  27. Thanks Devin,
    Great tutorial! You made my life much easier!

    Take care,
    Gilles

  28. Rick Upshaw wrote:

    I’m about to pull my hair out. The procedure described in this post and in the video works fine for me on my hostgator server. As soon as I’m finished, I can immediately access the newly created sub-domain. However, on another one of my servers (not hostgator), everything seems to work fine during the install, but when I go to try to visit the newly created site, nothing is there!

    I’m certain the problem has to be something on the server. My hosting company is willing to help me figure this out, but they don’t know what’s wrong anymore than I do, so if I’m going to get this to work on their servers, I have to be able to tell them what to fix!

    What do I do? Does anyone have any ideas? Anyone?

    • Max wrote:

      Probably is your hosting company. Many of them do not like you running Multi-Site on Shared hosting — quite simply as it taxes their machines — and you can run way more domains than they may allow using MU Domain Mapper.

      Hostgator are awesome and pretty much allow you to do anything, but will throttle you if you start to overload the web-server.

  29. ApniVideo wrote:

    nice plugin for the community, i’ll try to write an automation for domain mapping (SUNRISE) too, maybe will complete this plugin.

    ps. what font do you use in this theme because text in posts looks ugly in linux? :P Try not to use “Lucida Grande”,Calibri and other new microsoft fonts, they look ugly on other operating systems (mobile phones for example)

    • Devin wrote:

      It’s Helvetica Nueue, same font that Twenty Eleven uses.

  30. Agraj wrote:

    i’ve updated wp-config file but there is showing black in Network Admin menu, under tools..

    What to do..?

  31. Ty Disdier wrote:

    Thank you so much worked on the first try

  32. Lilia Lee wrote:

    Thank you so much for this posts. It helped quite a bit in getting the multiple site created.
    Unfortunately, the site I am supporting uses a custom-made theme that doesn’t seem to work on the secondary site I created. It is network enabled but the custom header and menu do not appear on the second site (I have a sub-directory install). oy vey!!!

    • Devin wrote:

      Menus and headers will have to be set on a per site basis unless you write some sort of automation script to set the options.

  33. thanks for the video! It’s one of the easier ones I found to help with the installation of MS.

    I just did it and found it fairly simple!

    thanks again,

  34. Kathy wrote:

    I followed your tutorial, but when trying to access the dashboard of my newly added site, I got the 404 (Page Not Found) Error page. Can you help me fix that?

    Thanks.

  35. Lauren kinde wrote:

    You’re a life-saver! I read countless tutorials and it kept failing…but after I watched your video, it works! Thank you!

  36. after the network setup i have used the copy the code of httaccess and wp-config and pasted as follwed by instruction and uploaded in server but mu is not working i am not getting the super admin and network adminstrator

  37. marisa wrote:

    do you have to have the site name registered first? And I’m assuming you do NOT want to have wordpress installed on that site? I keep getting error messages.

  38. hillman wrote:

    Hi Devin,

    Thanks for your video. I followed the multi-site instruction and created my wordpress site at http://homepage.ics.edu.hk. Then I tried to create site1 as a test. It said the new site1 is addred but when I view the site1 failed with an error:
    The requested URL /site1/wp-admin/ was not found on this server.

    It seems that the site1 did not create or somehow the path for the multisite is not configurated properly. Any hints or ideas on how to fix this problem. Thanks…. Hillman

  39. JJ wrote:

    Is there a way to make the search search all the sites? Does it already do that?

  40. Tomas wrote:

    I read other instructions and they say lots of things. Is this all we need to do – adding a single line of code? And then setting up subdomains in the wp dashboard?

  41. Amy wrote:

    Awesome, thanks!

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>